易优cms数据库版本不一致,怎么解决?

笔者从官方下载了v1.5.5空数据包文件,在安装易优cms1.5.5版本的时候,就出现了提示:“无法安装,数据库文件版本号(v1.5.4)与CMS源码版本号(v1.5.5)不一致。”

经常使用易优cms的朋友在使用易优cms建站的时候,可能会遇到如下图的提示。

易优cms数据库版本不一致,怎么解决?

比如,笔者从官方下载了v1.5.5空数据包文件,在安装易优cms1.5.5版本的时候,就出现了提示:“无法安装,数据库文件版本号(v1.5.4)与cms源码版本号(v1.5.5)不一致。”

笔者首先是按照提示,点开了“点击查看”,打开一个网页,但是并没有实际的解决方案(原网页如下图)。

易优cms数据库版本不一致,怎么解决?

针对这个问题,笔者只能本着‘先查源代码’的原则手动去核查,全局搜索了代码,最终在代码中找到了这段错误提示。

易优cms数据库版本不一致,怎么解决?

很明显,这是代码获取了eyoucms.sql文件中的Version值,然后与程序版本号进行比较,如果一致,正常执行,不一致,提示该错误。

知道了这个原理之后,解决起来就很简单了。

操作步骤

我们直接打开install文件夹中的eyoucms.sql文件,然后在其文件头部找到“Version : #v1.X.X”的字眼,比如Version : #v1.5.4,将1.5.4改成1.5.5即可。

其他的版本操作类似,就是改成与其cms版本号对应的数值。

为此,笔者也向官方技术人员反馈确认了这件事,官方技术人员给发来了一个新的空数据包,事实证明,笔者的分析是正确的,就是数据库文件版本号的出了问题而已。